1 Introduction

Vector network Analyzer (VNA) [1] is used to test component specifications and verify design simulations to make sure systems and their components work properly together. It contains both a source, used to generate a known stimulus signal, and a set of receivers, used to determine changes to this stimulus caused by the device-under-test or DUT. The stimulus signal is injected into the DUT and the VNA measures both the signal that’s reflected from the input side, as well as the signal that passes through to the output side of the DUT. The VNA receivers measure the resulting signals and compare them to the known stimulus signal. The measured results are then processed by either an internal or external PC and sent to a display.

VNA performs two types of measurements: transmission and reflection. Transmission measurements pass the VNA stimulus signal through the device under test, which is then measured by the VNA receivers on the other side. The most common transmission S-parameter measurements are S21 and S12 ($S_{ij}$ for greater than 2-ports). Swept power measurements are a form of transmission measurement. Some other examples of transmission measurements include gain, insertion loss/phase, electrical length/delay and group delay. Comparatively, reflection measurements measure the part of the VNA stimulus signal that is incident upon the DUT, but does not pass through it. Instead, the reflection measurement measures the signal that travels back towards the source due to reflections. The most common reflection S-parameter measurements are S11 and S22 ($S_{ii}$ for greater than 2-ports).

Advance Design System (ADS) is a circuit design and simulation software with extensive libraries and design guides. For this lab, we will prepare you with the basics for how to use ADS and VNA.

2 Background

LineCalc

LineCalc [2] is an analysis and synthesis program for calculating electrical and physical parameters of single and coupled transmission lines. LineCalc can communicate directly with the circuit simulators. You can send parameter data for selected circuit design elements, along with data on any associated substrates or walls, directly from the simulator to LineCalc. After the element parameter values are calculated, you can update the associated schematic or layout circuit design in the active simulator immediately with the LineCalc results. Or you can place a newly synthesized component into the Schematic window.

Using dialog boxes, you can make changes in parameter values of your transmission lines and see the results of those changes on the screen. You can use LineCalc like a spreadsheet, in the sense that a change in one value brings about a recalculation through all related values when you choose the appropriate Calculate button. You can print results, save results to an element data file, or instantly update a schematic or layout in a circuit design.

3 Pre-labs

1. For the circuit in Figure 1, calculate source reflection coefficient ($\Gamma_S$), load reflection coefficient ($\Gamma_L$) and first incident wave ($V_1$). You may refer back to your ECE329 notes for help.

2. Unbox NanoVNA and read its full user manual (https://nanorfe.com/nanovna-v2-user-manual.html). What type of wave is the signal generator sending? What are the measured items at the receiver?

4 Equipment

- Advanced Design System (ADS)
5 Procedure

Part I - ADS Walk-through

To get access to Keysight Advanced Design System (ADS), log in https://my.engr.illinois.edu/labcheck, then select Electrical and Computer Engineering to view current lab usage. Follow instructions on the screen to remotely access one of the EWS lab computers. Open ADS and create a new workspace. Make sure there is no space in the project folder path. To create schematic or data display, simply click File → New. Here is a inside look on the schematic window (Figure 2). Contact your TA if you are having trouble using ADS.

5.1 Transient Analysis

1. Create a new schematic named "Transient1". Draw the circuit with the given parameters as in Figure 3. Here are the components we used in the schematic. If you need more help in understanding a specific parameter, simply search the component name in ADS help menu or ask your TA.
2. Start the simulation. A data display window will automatically pop up. Click on Rectangular Plot and select the data sets as in Figure 4. Insert a data marker in the Impedance plot. The value should match with the impedance you set for TLIN in the schematic. Take a screenshot and include it in your report.

Figure 3: Transient1 Schematic.

- VtStep: Voltage source (step)
- TLIN: Ideal 2-terminal transmission line
- Tran: Transient/convolution simulation
- MeasEqn: Measurement expression
- V1, V2: Net labels (Use Insert Wire/Pin Label in the tool bar, type a name and click on the desired net)

Figure 4: Transient1 Data Display.
3. Create a new schematic named "Transient2". Draw the circuit with the given parameters as in Figure 5.

It is highly recommended that you check out what MLIN and MSUB actually look like (3D) in ADS help menu. Different from TLIN, which is an ideal transmission line that does not have a physical shape, MLIN is a copper trace that is built on a board with MSUB specifications (just like the student board you received).

- MLIN: Microstrip Line
- MSUB: Microstrip Substrate

![Figure 5: Transient2 Schematic (before updates from LineCalc).](image)

4. To start LineCalc, click Tools → LineCalc → Start LineCalc. Select MLIN component and then click Tools → LineCalc → Send Selected Component to LineCalc.

5. As in Figure 5, the MSUB info will be automatically updated in the lineCalc. Change Freq, Z0 and E_Eff values to match with the previous TLIN you built. Click Synthesize to let LineCalc calculate microstrip’s width and length for you. To Send the calculated values back to the schematic, click Tools → LineCalc → Update Selected Component from LineCalc.

6. Start the simulation and plot the data sets as you did for TLIN. Insert the data marker in the Impedance plot at the same time stamp (e.g. time = 1.313 nsec). Take a screenshot and explain in the report whether your impedance value matches with the previous result.
7. In the same data display window, insert equations and graphs as shown in Figure 6. \( fs \) is an ADS built-in function that performs time-to-frequency transform. For a step function with certain delay, what is its expected frequency domain waveform? Explain if the plots of \( h1 \) meets your expectation.

![Figure 6: Transient2 Data Display of Time-to-Frequency Transform.](image)

5.2 S-parameter Analysis

1. Create a new schematic named "Sparam1". Draw the circuit with the given parameters as in Figure 7. You might not be familiar with the components we used here; the lecture will soon cover them.

   - Term: Port impedance for s-parameters
   - S_Param: S-parameter simulation

![Figure 7: Sparam1 Schematic.](image)

2. Start the simulation. In the data display window, choose Rectangular Plot to plot out \( S_{21} \) (dB and phase). Choose Smith Plot to plot out both \( S_{11} \) and \( S_{21} \). After that, double click on the traces to edit their properties: thickness, line type, etc. You may improvise the styles as long as the graph is clearly legible. For future labs, we will not remind you to do this step. However, it is your duty to label the graphs and making them easy to read. Points will be deducted for any blur or messy plot. Your results should match with the values showing in Figure 8. Take screenshot and include it in your report.
3. To save the simulation results you just ran, click Tools $\rightarrow$ Data File Tool. Select Write data file from dataset and choose Sparam1 as the dataset to read from. Save the 2-port s-parameter file (.s2p) in dB/Angle format. Confirm by clicking Write to File (Figure 9).

4. Create a new schematic named "Sparam2". Draw the circuit with the given parameters as in Figure 10.
   - SnP: N-port s-parameter (number of ports update itself automatically after file import)
5. Start the simulation. Draw the same data display as you did for Sparam1. Your result of Sparam2 should be EXACTLY the same as the one of Sparam1. Take a screenshot and explain in the report if you see any discrepancy. Save the 2-port s-parameter file (.s2p) for python post-processing in the conclusion section.

5.3 Useful Tools (Sweeping Variables)

There are multiple methods ADS provided for variable sweeping. Feel free to explore more as the semester goes.

1. Create a new schematic named "Batch". Draw the circuit with the given parameters as in Figure 11.
   - VAR: define multiple variables or equations
   - BatchSimController: Batch simulation controller (MUST specify the variation and the analyses to run)
2. Start the simulation. The impedance of TLIN is defined as a variable here (from 40 Ω to 120 Ω with a step of 10 Ω). Insert a Line Marker in the impedance plot so you can see all 9 values simulated. Your result should look like [Figure 12]. Take a screenshot and include it in your report.

![Impedance Plot]

**Figure 12**: Batch Data Display.

### Part II - VNA Walk-through

This is a simple walk-through to get you familiarize with NanoVNA. Although there is no write-up required for this section, the following information is crucial to your knowledge of using lab equipment.

#### 5.4 Installation

1. Install the software for NanoVNA here: [https://github.com/nanovna-v2/NanoVNA-QT/releases](https://github.com/nanovna-v2/NanoVNA-QT/releases). Note that you should install the driver first before downloading the latest version of vna_qt_windows.zip.

2. Extract the zip file to your local drive. In folder release, double click vna_qt.exe to run the software. We recommend you to create a shortcut of it on desktop.

3. Connect NanoVNA to your PC using the cable provided. Click Device and select //./COM4 (you may have a different port number). Traces will appear in the viewing window if the connection is successful.

#### 5.5 User Interface

1. In VNA View, there are options for you to calibrate, measure, view and save the s-parameter. You will be exposed to the details of calibration in lab 4. Here we are presenting to you the solo basics of what to expect.

2. Two types of plotting are provided by default: smith chart & magnitude (dB). In the drop down menu right above the rectangular plot, you can choose different items to plot. Two traces are allowed on both of the plots simultaneously. You may notice the traces are constantly flickering: This is due to the nature of s-parameter measurement, where a source continuously send out signal. The reading on the graph is the instant response for each pulse, thereby a small flickering/variation is considered normal.

3. To change the frequency range, click Device→Sweep Parameters as shown in [Figure 13]. You can adjust the start and end frequency as well as the number of points. Keep in mind that you will need to change this setting every time you open the software. It is always a good practice to do sanity check on this menu each time BEFORE performing calibration.

4. There are two types of s-parameters files you can save in VNA View: 1-port (.s1p) and 2-port (.s2p). To save .s1p file, simply click S parameters→Export s1p (port 1). To save .s2p file, click S parameters→Capture S*1 / S*2→Export s2p. You screen will freeze (no panic) during capturing if you have a large number of points.
6 Conclusion

1. In your data display window for Transient1, put a data maker on the voltage plot of $V_2$. Is this result the same as you had in pre-lab question 1? Take a screenshot and include that in your report.

2. Import the .s2p files you got from Sparam1 and Sparam2 to Jupyter notebook. Attach the following plots to your report (make sure you have both data sets on the same plot):
   - $S_{21}$ Magnitude (dB)
   - $S_{21}$ Phase
   - $S_{11}$ Real
   - $S_{11}$ Imaginary
   - $S_{21}$ Smith Chart
   - $S_{11}$ Smith Chart

3. In your Batch schematic, define another variable "$Y=120". Make Electrical length (E) of TLIN now equals to Y. Add a Sweep of Y from 90 to 150 with a step of 30. Start the simulation and observe the result by inserting the line marker. How many values you are expected to get? How many values are ADS displaying?

References