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This chapter introduces the Broadband SPICE Model 
Generator, discusses its benefits and provides an overview of 
the Broadband SPICE Model Generator use model. It also 
introduces the Broadband Spice UI, including the standard, 
advanced input and advanced output option tabs.
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1 Broadband SPICE Model Generator
Broadband SPICE Model Generator Overview

The Broadband SPICE Model Generator tool converts 
frequency domain network parameter data of passive 
components (obtained by measurements and/or simulations) 
into equivalent circuit models for direct use with 
commercially available circuit simulators.

The Broadband SPICE Model Generation tool supports input 
model data available in a number of different file formats. 
This includes measured data, as well as, data generated by 
EM and frequency- domain simulators for ease of use. It also 
supports output model data in several different file formats, 
so that the data can be easily used with a number of 
different circuit simulators (e.g., transient, frequency domain, 
envelope and harmonic balance).

Supported Operating Systems

Broadband SPICE Model Generator is supported on all 
operating systems supported by ADS. See the ADS 
Installation Manual for more details.

Accessing the Documentation 

To access the documentation for Broadband SPICE Model 
Generator, from any ADS window select Help > Topics and Index 
> Model Development > Broadband SPICE Model Generator, or from 
the Broadband SPICE Model Generator main menu select 
Help > Topics and Index. 
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Broadband SPICE Model Generator Use Model

The following diagram outlines the process flow for the 
Broadband SPICE Model Generator engine:

Figure 1 Broadband SPICE Model Generator Process Flow Chart
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1 Broadband SPICE Model Generator
Using Broadband SPICE

Broadband SPICE State File

Broadband SPICE uses ascii state files (.stf) to save and 
recall tool dialog settings. 

A default state file is provided with Broadband SPICE. This 
is used to initialize the Broadband SPICE dialogs with the 
default values. The default state file, named bbs_default.stf is 
located in the $HPEESOF_DIR/bbspice/config directory.

The default Broadband SPICE state file is configurable on a 
<project>/<user>/<site> basis like other ADS tools.

Following is an example of a Broadband SPICE application 
state file: 

input.isMeasuredData 0;
model.dataSampling All;
model.targetAccuracy 5.000000e-3;
model.autoGenerate 1;
fitting.globalPolesImposed 1;
fitting.minDeltaPolesZeros -1;
fitting.maxDeltaPolesZeros 0;
fitting.maxVFIterations 5;
fitting.leastSquareMode NORMAL;
fitting.normalizeMatrix 1;
fitting.useRelaxation 0;
passivity.mirrorPolesIntoLHP 1;
passivity.enabled 1;
passivity.maxPreDataTruncation 9.999000e-001
passivity.maxNrIterations 5;
passivity.maxPostModelScaling 9.950000e-001;
output.spice2g6 0;
output.spice3 1;
output.agilentModel 1;
output.useInputDir 0;
output.path networks/;
dataset.generate 2;
dataset.path data/;
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Starting Broadband SPICE

To start the Broadband SPICE tool select Tools > Spice Model 
Generator > Start Broad Band Generator from a Schematic 
window.

Figure 2 Starting the Broadband SPICE Model Generator.
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1 Broadband SPICE Model Generator
The Broadband SPICE Main Window

This window offers three option tabs, Standard, Advanced 
Input and Advanced Output. These options are described in 
detail in the following sections.

In the simplest operation, it is only necessary to specify the 
input filename and file type before generating a model. In 
this case, the engine generates and uses the values for the 
advanced options based on its processing of the input data 
and the information contained in the default Broadband 
SPICE state file. The output file types and directory 
placement have been selected to easily facilitate the use of 
these models in ADS.

Figure 3 The Broadband SPICE Main Window
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Standard Options Tab

Figure 4 Standard Options Tab

The following dialogs are available under the Standard 
Options tab:

Input Dialog

The input data used by Broadband SPICE must contain 
S- parameter information with reference impedance of 50 Ω.

File type The following Input files are supported by 
Broadband SPICE:

Dataset: ADS binary format
Citifile:

Touchstone:

NOTE If only other network parameters are available (e.g., Y, Z, H, ABCD, etc...) 
an up front transformation to S-data is required.
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Momentum RAT: Momentum rational (.rat) files are the 
output result of a Momentum AFS simulation. These 
files contain information about the rational fitting 
model of a single Momentum simulation and are 
located under the <mom_dsn>/<layout_name> directory 
of your project. When using this file type, you must 
provide the .rat filename (generally <proj>.rat). It is 
preferred, but not required, that the .sam file is in the 
same directory as the .rat file. This .sam file contains 
information about the frequency samples chosen by the 
Momentum AFS algorithm. We recommend that you use 
the name of your layout as a prefix for the output 
model files.

Input parameter data must have a reference impedance 
of 50 ohms.

Default: None specified

Input data is from measurement Specifies whether or not the 
input data is measured data.

A slightly different rational fitting algorithm (using 
relaxation) is used in model generation when this box is 
checked. Selecting this box is recommended if the input data 
is noisy. If the default fitting procedure does not converge, 
this option can be switched on or off.

NOTE Momentum is an Agilent 3-D planar electromagnetic simulator integrated 
into ADS and RFDE.
12 Broadband SPICE Model Generator
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Default: unchecked

Input file name Enables you to select your input file. This 
can be done by typing the path and filename, or by selecting 
the Browse button.

Output Dialog

This dialog enables you to select the type of models that are 
generated by the Broadband SPICE Model Generator tool. 

File type Two model files, <filename>.ckt and 
<filename>.bbn are created when you select the ADS 
checkbox. 

These file types are 2 different versions of the Broadband 
Spice model represented by ADS netlists. The <filename>.bbn 
netlist describes a polynomial representation, while the 
<filename>.ckt netlist is an ADS version of the spice3 
format. 

In some cases, the generation of the rational polynomial 
model will fail due to numerical representation inaccuracies. 
In this case a warning is issued and only the <filename>.ckt 
model file is created. 

The preferred input file type for simulations in a schematic 
layout using a Broadband SPICE component is 
<filename>.bbn. 

If SPICE3 is selected, a <filename>.sp3 file is created. This 
file can also be used in hspice simulations.

If SPICE2 is selected, a <filename>.sp2 file is created. This 
format is not recommended, since it requires the engine to 
perform extra transformations which could diminish the 
accuracy of the output.

NOTE The <filename>.bbn and <filename>.ckt files are used with BBSnP circuit 
components in ADS schematics. For more information on using these files 
in ADS, refer to “Using Broadband SPICE Models in ADS” on page 44
Broadband SPICE Model Generator 13
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If the .s2p file is used, it is possible that a number of 
warnings will be issued with regard to the magnitude of the 
lumped elements. These warnings can be ignored.

Default: ADS and SPICE3

Output log This window displays status messages regarding 
various Broadband SPICE operations (e.g., model 
generation).

Figure 5 Output Log

To clear this window select Clear.

The Advanced input options located directly above the 
Output log indicates the status of the advanced options. It 
will either read automatic or specified. 

NOTE If you require a SPICE output, we recommended that you use the SPICE3 
format and not the SPICE2 format.
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If automatic, the input data- dependent advanced option 
values are automatically calculated during model generation. 
If specified, the input data- dependent advanced option 
values specified in the dialog will be used.
Broadband SPICE Model Generator 15
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Advanced Input Options Tab

Figure 6 Advanced Options Tab

The following dialogs are available under the Advanced 
Input Options tab:

Input File-dependent Options Dialog

Certain advanced input options are highly dependent on the 
input data. These values are initially disabled in the dialog 
and cannot be modified. It is possible that model generation 
will fail, or will produce inaccurate results if these option 
values are not consistent with the input data. Because of 
this it is recommended that you let the engine calculate 
these values automatically during model generation. However, 
if desired, these option values can be specified manually in 
the dialog. The next section describes how this can be done.

Use auto-generated values determined at run-time When this 
checkbox is checked the Broadband SPICE engine determines 
the optimum values to be used, during model generation 

NOTE The Advance Input Options tab page can only be accessed after a valid file 
name and type have been specified on the Standard Options tab.
16 Broadband SPICE Model Generator
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run- time, based on the values present in the input file. 
When this checkbox is checked, only Amplitude threshold 
and Fitting tolerance values are editable.

When un- checked, the values shown in the dialog will be 
used during model generation, and all fields are enabled for 
editing. If the current values are un- initialized (as indicated 
by Number of frequencies set to “- 1” or “unspecified”) 
un- checking this checkbox will cause all dependent option 
values to be generated and initialized in the dialog with the 
recommended values.

Re-generate values Clicking this button causes all of the 
input file- dependent options to be re- generated and set back 
to their recommended values. This button is enabled only 
when the Use auto- generated values determined at run- time 
checkbox is un- checked.

Default: Checked

Figure 7 Re-generated Values

NOTE The engine is run to initialize or re-generate the option values. This 
operation normally takes only a few seconds. When the operation has 
finished the values in the dialog are updated automatically.
Broadband SPICE Model Generator 17
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Data (S-Parameter) dialog

Number of frequencies This is the number of frequency 
points of the original input data. This value cannot be 
changed manually. A value of “- 1” or “unspecified” indicates 
that the values shown in the dialog are un- initialized, and 
that they will be re- calculated and updated the next time 
either the Use auto- generated values determined at 
run- time checkbox is un- checked, or the Re- generate values 
button is pressed.

Minimum frequency and maximum frequency These values 
specify the minimum and maximum frequency of the input 
data to be used when the output models are generated. The 
recommended, initial values correspond to the minimum and 
maximum frequencies specified in the input data. When 
modifying these fields the following rules must be followed:

• The new minimum frequency may not be less than the 
minimum frequency of the input data.

• The new maximum frequency may not be greater than the 
maximum frequency of the input data.

• The minimum frequency may not be greater than the 
specified maximum frequency.

Data sample This dropdown box specifies the number of 
data samples used when generating the output model, 
relative to the Number of frequencies (defined above) in the 
input data.

A distinction should be made between the different types of 
input files when using this option. Different file types 
provide better results if the following rules are applied.

• Momentum RAT: The recommended setting is AllX2

NOTE Changing these fields is not recommended.
18 Broadband SPICE Model Generator
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Momentum saves a limited number of data points in the 
.rat and .sam files. Therefore, the preferred setting is 
AllX2. However, All or AllX5 may also be used.

• Dataset, Citifile and Touchstone: The recommended 
setting is ReducedX20

The fields All, ReducedX2, ReducedX5, ReducedX10, 
ReducedX20 and ReducedX50 can all be selected. 
Reducing the number of data points may be helpful, 
especially if there are a large number of frequencies in 
the input data and the number of poles is limited. This 
can provide a large time gain without any loss of 
accuracy. If a chosen reduction removes too many data 
points, a warning is issued and an automatic switch to a 
less coarse reduction scheme is executed.

Amplitude threshold To facilitate passivity later on, the 
singular values of the S- parameters are upper limited to the 
amplitude threshold. If the singular values of the 
S- parameters are greater than 1, by definition, the input 
data is not passive (this may be caused by measurement 
noise or numerical simulation inaccuracies). 

Limiting the max value of the input data to the specified 
Amplitude threshold value is a preprocess passivity 
enforcement step which is applied on all discrete data 
samples. The recommended value is 1 or slightly less than 1 
(e.g., 0.9999).

If you wish to skip this preprocess step, you can specify a 
very large value (e.g., 100 or so). This is not recommended.

Default Value: 0.9995

Model

The input data is used to generate a rational model. This 
model has the form of a series expansion in partial 
fractions: 
Broadband SPICE Model Generator 19



1 Broadband SPICE Model Generator
The factors rn are the residues, while pn are the poles. In 
total, there are N such terms:

Depending on the dynamics of the input data, the number of 
terms (N) varies.

So, the number of poles (and thus terms) is dependent on 
the input data. The recommended range for the number of 
poles is based on the analysis of the dynamics of the input 
data. You are free to modify this number if desired.

Number of poles: Minimum, maximum and step The 
recommended, initialized values are calculated based on the 
dynamic behavior of the input data.

If the fitting process does not converge, or if passivity 
enforcement fails, changing the number of poles may lead to 
convergence and passivity. This is especially true for noisy 
data, when it can be difficult to estimate the Minimum and 
Maximum number of poles of the system.

Step defines the sweep step within the interval [Minimum, 
Maximum] number of poles. It is by definition larger or 
equal to zero and smaller than |Maximum – Minimum| 
number of poles.

Fitting tolerance This is the allowed root mean square (RMS) 
fitting error. It is the criterion to decide if the rational fit 
will be successful or not. If the RMS value of the rational 
model fitted data is less than the fitting tolerance, the model 
is considered to be converged.

rn
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N

∑
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The recommended setting for this value ranges between 
0.001 to 0.02. 

Default Value: 0.005

Fitting

Use global poles Checking this box causes all S- parameters 
to share a common set of poles. This setting is advised if the 
number of ports is limited. If the number of ports is higher 
(typically above 4), un- checking this box may increase the 
speed of the fitting process, but significantly decrease the 
speed of the passivity enforcement process.

Default: Checked

Strictly proper If the Strictly proper box is checked, the 
following properties are valid:

N = D – 1, with N the polynomial degree of the numerator and 
D the polynomial degree of the denominator of the rational 
model.

If the box is un- checked, the rational model is called proper 
and (D - 1) ≤ N ≤D.

Default: Un- checked

Mirror poles into left-half plane This parameter forces the 
non- physical poles to be mirrored into the left half complex 
plane. Note that poles must be in the left half plane in order 
to obtain a passive model. If fitting convergence fails, 
modifying this field can lead to convergence.

Default: Checked

NOTE If passivity for very high frequencies is desired, selecting Strictly proper is 
recommended.
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Matrix solver This field enables you to control the speed 
versus accuracy of the model generation. If there are many 
ports and data samples, Normal equations is the preferred 
setting. If accuracy is the most important criterion and 
speed is not essential, then Singular value decomposition 
should be selected. If none of these factors are important, 
and if the number of poles and ports are limited QR 
factorization may be used.

Default: Normal equations

Maximum number of iterations (Fitting) This is the number of 
pole relocation steps (≥1). The higher this value, the more 
time it can take for model generation. Values between 4 and 
7 are recommended.

Default: 5

Passivity

Enforce passivity This enables you to select whether the 
passivity of the rational model will be checked or imposed.

If passivity enforcement is not selected, the output files are 
generated based on the rational fitting model. If passivity 
enforcement is selected, an additional post- processing step is 
performed, which can modify the coefficients of the fitting 
model to ensure passivity. After this step is executed, the 
output files are generated based on the (passivity enforced) 
rational fitting model.

Default: Selected
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Maximum model scaling This is an optional scaling factor, 
only meant to suppress minor (remaining) passivity 
violations. For example, if a maximum passivity violation of 
1.0001 remains after passivity enforcement, a scaling of the 
broadband model by 0.9999 will resolve all remaining 
passivity issues.

It is the very last step in a series of passivity enforcement 
actions and equally affects all frequencies (from DC to 
infinity). The Maximum model scaling is the lower end of 
the scaling factor allowed to be used to enforce passivity.

If the you want to skip this post processing step, specify an 
input a value ≥ 1 in this field.

The recommended setting is slightly less than 1 (e.g., 0.999).

Default Value: 0.995

Maximum number of iterations (Passivity) This is the number 
of passivity enforcement steps.

If the value is set to 0, passivity is not enforced, although a 
passivity check is performed on the rational fit model.

Default: 5

NOTE If passivity enforcement is not selected, all output files will contain the 
rational fitting model of the input data. If passivity enforcement is 
selected, all output files contain the passive rational fitting model of the 
input data.
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Advanced Output Options Tab

Figure 8 Advanced Output Options Tab

The following dialog is available under the Advanced Output 
Options tab.

Intermediate dataset

This dialog enables you to select whether or not to save a 
dataset of the rational model, select a prefix name for this 
dataset and choose a directory in which to save it. 

Data directory selector Using this dialog you can choose to:

• Not save a data set

• Save the dataset in the input file directory

• Use a specified directory

If you select the Use directory specified below radial 
button, you can supply a directory path directly, or use 
the Browse... button to find the desired location. This 
path defaults to the current projects data directory.

NOTE The Advanced Output Options tab can only be accessed once a valid file 
name and file type have been specified on the Standard Options tab page.
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Dataset name prefix This enables you to choose a unique 
name for the output dataset.

Dataset name Lists the current path and dataset name to be 
used for the output file. When a new path is selected the 
current path and dataset name are automatically updated.
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Broadband SPICE Model Generation

Once the model generation options have been specified, you 
may begin model generation by either selecting Model 
Generation > Start from menu bar on the main Broadband 
Spice Model Generator window or by choosing the Start 
Model Generation icon from the main toolbar.
26 Broadband SPICE Model Generator
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This chapter illustrates how to use the Broadband SPICE 
Model Generator tool to create broadband spice models for 
use in ADS and other circuit simulators.
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Creating Models with Broadband SPICE Model Generator

The Broadband SPICE Model Generator enables you to easily 
create broadband SPICE models for use in ADS and other 
simulators. The following section offers an example of model 
creation using a single via passive component (based on 
full- wave EM field simulation data) and another example of 
coupled microstrip lines (with input from measurements).

Broadband SPICE Model Generation Examples

Overview

The following examples, show how to use the Broadband 
SPICE Model Generator tool to create broadband SPICE 
models for 2 passive circuit components based on 
S- Parameter data (obtained through either measurements or 
simulations). Later in Chapter 3, “Using Broadband SPICE 
Models” the generated broadband SPICE models will be used 
in an ADS frequency- domain and time- domain circuit 
simulation. The initial S- Parameter data will be compared 
with the generated broadband SPICE models. It will be 
shown that the Broadband SPICE Model Generator tool 
successfully produced accurate, broadband models of the 
S- Parameter data, and that these broadband SPICE models 
can be easily used in the ADS circuit simulators.

Input Data

The SPICE Model Generator tool can use S- Parameter data 
files, in several standard file formats, as inputs. 

NOTE The data used for these examples was obtained from Wendemagegnehu T. 
Beyene from Rambus Inc.

NOTE The input data can be either measured or simulated. 
28 Broadband SPICE Model Generator
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Model Creation Using a Package Via Structure

This example uses S- Parameter data obtained from passive 
circuit elements as the input data for the broadband SPICE 
model generation. 

The example file is located in the Agilent EEsof Knowledge 
Center at:

https://edasupportweb.soco.agilent.com/cgi- bin/show.pl?id=27
5600

Select Software Downloads > ADS > ADS 2006 > ADS 2006 Update 1 > 
BBS_Training

The input data for this example is from a package single via 
structure. The 2- Port S- Parameter data, in Touchstone file 
format, was obtained from simulations using a full- wave 
(3D) electro- magnetic field solver. 

Input touchstone file name: SingleVia.s2p 

Equivalent dataset file name: REF_SingleVia.ds

The following section illustrates how to use the ADS 
Broadband SPICE Model Generator tool to create an 
accurate SPICE model from the input S- Parameter data. 

1 Start ADS.

2 Select File > Unarchive Project... and unarchive the file:

BBS_Training.zap

3 Open a Schematic window

4 From the Schematic window main menubar, select Tools > 
Spice Model Generator > Start Broad Band Generator to open the 
Broadband SPICE Model Generator tool.

NOTE This project file contains the input data files to be used in this example 
during broadband SPICE model generation, as well as, schematics and 
data displays that will be used to verify the results.
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2 Creating Broadband SPICE Models
Figure 9 Broadband SPICE Model Generator Main Window

Setting up the Broadband SPICE Model Generation Tool

This section explains how to set up the tool to generate 
broadband SPICE models.

1 From the Input section of Broadband SPICE Model 
Generation Tool Standard Options tab, select Touchstone in 
the File type dropdown menu
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2 Click the Browse button associated with Input File Name 
dialog and select SingleVia.s2p from the Browse window.

3 In the Output section, check ADS as the Output File Type.

4 Type “Model_” in the Output file name prefix dialog box.

NOTE You must select a File type from in the Input section to access the 
Advanced Input and Advanced Output options tab
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5 Next, click the Advanced Input Options tab.

6 Un- check the Use auto-generated values, determined at run-time 
check box.

Un- checking this box causes the engine to generate 
recommended initial values for the input data- dependent 
options, and activates the deactivated selections in the 
Independent file- dependent options section.
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7 In the Data Sample section of this window, select 
ReducedX50 from the dropdown menu

8 Click the Advanced Output Options tab.

9 Ensure that the Dataset name prefix is set to Model_.

Broadband SPICE Model Generation

Once the Standard, Advanced Input and Advanced Output 
options have been set, you are ready to begin the model 
generation process. 

1 To begin model generation, select Model Generation > Start 
from the Broadband SPICE Model Generation main menu.

Note that once the model generation has started, the tab 
automatically switches to the Standard Options page. This 
enables you to review the model generation status and 
view other information available in the Output log dialog.

NOTE The engine is run to initialize or re-generate the option values. This 
operation normally takes only a few seconds. When the operation has 
finished the values in the dialog are updated automatically.

NOTE The only Advanced Option setting having an affect on the output model 
calculation, changed from its recommended value for this example, was 
Data sample.
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Figure 10 Output Log

For this example 3 output files are generated:

• <output_dir>/Model_SingleVia.bbn

• <output_dir>/Model_SingleVia.ckt

• <dataset_dir>/Model_SingleVia.ds

2 Model creation is now complete. To exit the Broadband 
SPICE Model Generation Tool, select File > Exit

3 Click No if the Save Changes dialog that appears.

4 Exit ADS.

This completes the example for using the ADS Broadband 
SPICE Model Generator tool to create broadband SPICE 
models (.bbn and .ckt) for a single via passive circuit 
element.

For information on how to use and verify these models in 
ADS, refer to, “Using Broadband SPICE Models in ADS” on 
page 44 of this manual.
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Model Creation Using an FR4 Coupled-Microstrip Lines 
Circuit

This example uses S- Parameter data obtained from passive 
circuit elements as the input data for the broadband SPICE 
model generation.

• The input data for this example was obtained from 2 
6- inch long FR4 coupled- microstrip lines circuit and 
4- Port S- Parameter data, in touchstone file format, 
obtained from Vector Network Analyzer measurements.[1]

Input touchstone file name: CoupledMicrostrip.s4p 

Equivalent dataset file name: REF_CoupledMicrostrip.ds

The following section illustrates how to use the ADS 
Broadband SPICE Model Generator tool to create an 
accurate SPICE model from the input S- Parameter data. 

1 Start ADS.

2 Open BBS_Training_prj.

3 Open a Schematic window

4 From the Schematic window main menubar, select Tools > 
Spice Model Generator > Start Broad Band Generator to open the 
Broadband SPICE Model Generator tool.

NOTE This project file contains the input data files to be used in this example 
during broadband SPICE model generation, as well as, schematics and 
data displays that will be used to verify the results.
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Figure 11 Broadband SPICE Model Generator Main Window

Setting up the Broadband SPICE Model Generation Tool

This section explains how to set up the tool to generate 
broadband SPICE models.

1 From the Input section of Broadband SPICE Model 
Generation Tool Standard Options tab, select Touchstone in 
the File type dropdown menu.

2 Click the Browse button associated with Input File Name 
dialog and select CoupledMicrostrip.s4p from the Browse 
window.

3 In the Output section, check ADS as the Output File Type.

NOTE You must select a File type from in the Input section to access the 
Advanced Input and Advanced Output options tab
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4 Type “Model_” in the Output file name prefix dialog box.

5 Next, click the Advanced Input Options tab.

6 Un- check the Use auto-generated values, determined at run-time 
check box.

Un- checking this box causes the engine to generate 
recommended initial values for the input data- dependent 
options, and activates the deactivated selections in the 
Independent file- dependent options section.

7 In the Data Sample section of this window, select 
ReducedX50 from the dropdown menu

8 Click the Advanced Output Options tab.

9 Ensure that the Dataset name prefix is set to Model_.

NOTE The engine is run to initialize or re-generate the option values. This 
operation normally takes only a few seconds. When the operation has 
finished the values in the dialog are updated automatically.

NOTE The only Advanced Option setting having an affect on the output model 
calculation, changed from its recommended value for this example, was 
Data sample.
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Model Generation for the FR4 Coupled-Microstrip Lines 
Circuit

Once the Standard, Advanced Input and Advanced Output 
options have been set, you are ready to begin the model 
generation process. 

1 To begin model generation, select Model Generation > Start 
from the Broadband SPICE Model Generation main menu.

Note that once the model generation has started, the tab 
automatically switches to the Standard Options page. This 
enables you to review the model generation status and 
view other information available in the Output log dialog.

2 Check the Output log.

Figure 12 Output Log

Notice that during the simulation run, the status window 
indicates the rational model did not converge (an RMS 
error of 0.03446 was obtained, while the default RMS 
tolerance is 0.005). You should also notice that Passivity 
enforcement was successful. 

One possible way to improve RMS accuracy is to use the 
Input data is from measurement option.
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3 On the Standard Options tab check the Input data is from 
measurement checkbox. Leave all other settings as they 
were.

4 Re- run the simulation.

Figure 13 Improved convergence, using the Input data is from measure-
ment option.

The Output Log now shows an RMS accuracy of 0.01847, 
which approximately two times better than the previous 
simulation. 

For this specific simulation, the model generation time 
took much longer than in the first example. This is due to 
the higher number of ports and the strong dynamical 
behavior of the input data, which leads directly to a high 
number of poles. If the passivity of the model is of minor 
importance, the execution time of the engine can be 

NOTE If the accuracy of the rational model is insufficient, it is possible that 
selecting the Input data is from measurement option will improve the 
accuracy. This is independent of whether or not the data is from an actual 
measurement.
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decreased importantly by not checking the Enforce 
passivity parameter in the Passivity box of the second 
tab Advanced Input Options.

If passivity is not important, but if you'd like to know 
whether the rational fitted model is passive, you can 
select the Enforce passivity parameter and set the 
Maximum number of iterations to zero. In this example 
the rational fitting model was already passive.

If passivity of the model is not important, the fastest way 
to obtain a model is to uncheck the Use global poles 
option in the Fitting box of the Advanced Input Options 
tab.

In this example only 2 output files were generated:

• <output_dir>/Model_CoupledMicrostrip.ckt

• <dataset_dir>/Model_CoupledMicrostrip.ds

In this example the .bbn file was not generated. This is 
because as the number of poles increase, numerical 
inaccuracies can occur. However, the .ckt file can still be 
used in an ADS schematic to obtain the desired results. It 
should be noted that if both ADS model files are written, 
the .bbn file is the preferred file type.

5 This completes the Model creation. Select File > Exit to exit 
the Broadband SPICE Model Generation tool.

6 Click No if the Save Changes dialog that appears.

7 Exit ADS.

This completes the examples for using the ADS Broadband 
SPICE Model Generator tool to create broadband SPICE 
models (.bbn and .ckt).

For information on how to use and verify these models in 
ADS, refer to, “Using Broadband SPICE Models in ADS” on 
page 44 of this manual.
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This chapter explains how to use the models created with 
the Broadband SPICE Model Generator in ADS.
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Using Broadband SPICE Models in ADS

Verifying the Rational Fitting Model Data for the SingleVia 
Structure

Overview

Previous examples showed how to create models using the 
Broadband SPICE Model Generator. In this chapter we will 
offer some explanation on how to use these models in ADS.

To begin with we will show how to verify the Broadband 
SPICE rational model data:

1 Start ADS.

2 Open a Schematic window, from the ADS Main windows 
menubar choose Window > New Data Display, to open a Data 
Display window.

3 From the Data Display’s main menubar select Tools > Data 
File Tool.

4 From the Data Files Tools main window, select the radial 
button for “Read data file into data set”. Select Touchstone 
as the “File format to read”, browse to “SingleVia.s2p” 
(the model generation input data) and type REF_SingleVia 
into the field provide for the dataset name.
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5 Click the Read File button to finish the process. 

6 Close the Data File Tool.

7 From the Data Display window Select the Smith Chart 
icon  from the left toolbar to insert a Smith Chart 
plot onto the Data Display window.
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8 Insert 2 traces onto the Smith Chart:

• REF_SingleVia.S

• Model_SingleVia.S_50

The following plot should appear in the Data Display 
window:

NOTE Model_SingleVia.ds is the dataset containing the rational fitting model of 
the SingleVia data created and saved during the model generation in the 
first example.
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Figure 14 Input and Output Comparison of S-Parameters using a Smith 
Chart Plot.

The red trace plots the input data, and the blue trace 
plots the generated, rational model data. This plot 
demonstrates that there is no noticeable difference 
between the two and that the generated rational model is 
an accurate representation of the input model data.

9 Close the Data Display window.
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Verifying the Output Model for the SingleVia Structure

1 Start ADS.

2 Open a Schematic window, select File > Open Design. Locate 
and open the design SingleViaFreqdomain.dsn

3 The following circuit should appear in the Schematic 
window.

Figure 15 SingleViaFreqdomain.dsn

4 Double- click the SNP data item to bring up the Edit 
Parameter window.
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5 Click the Browse button with the Touchstone file type 
selected.

6 Select the file SingleVia.s2p, then click Open and OK.

7 Double- click the BBS2P component BBS_BBN to bring up 
the Edit Parameter window.

8 Click the Browse button with the ModelFile parameter 
selected.

9 Select the file Model_SingleVia.bbn, click Open in the 
Select File window and OK in the Edit Parameter window.

10 Double- click the BBS2P component BBS_CKT to bring up 
the Edit Parameter window.

11 Click the Browse button with the ModelFile parameter 
selected.

12 In the Select File window, set the filter to All Files (*.*). 
Then select the Model_SingleVia.ckt file.

NOTE Model_SingleVia.bbn is the ADS broadband SPICE output model file that 
was created and saved during the Broadband SPICE Model Generation. 
The BBS2P component in the schematic now represents this model, 
which will be used when the frequency circuit simulation is run.
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13 Select Simulate > Simulate from the Schematic window 
main menubar to perform the simulation. 

When the simulation finishes, a Data Display window is 
opened: SingleVia_FreqDomain.dds.

From the schematic representation in Figure 15 on page 48, 
it is clear, for example, that S(1,1) should be equal to S(3,3) 
and S(5,5). This confirms the correctness of the ADS models 
and shows that the broadband SPICE generated output 
models are an accurate representation of the input model.
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Using the SingleVia Structure Model in the Time Domain

1 In a Schematic window, select File > Open Design. Locate 
and open the design SingleVia_TimeDomain.dsn

2 The following circuit should appear in the schematic 
window.

Figure 16 Transient Simulation of a Broadband SPICE component

A transient simulation of the model represented by the 
BBS2P component has been set- up in this schematic. The 
following steps will ensure that the BBS2P component is 
set- up to correctly represent the Broadband SPICE model 
generated in Chapter 2. 

3 Double- click the BBS2P component. To bring up the Edit 
Parameter window.

4 Click Browse button with the ModelFile parameter 
selected.

5 Select the file Model_SingleVia.bbn, click Open.

NOTE Model_SingleVia.bbn is the ADS broadband SPICE output model file 
created and saved during the Broadband SPICE Model Generation. 
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6 Click OK to dismiss the Edit Parameters dialog.

7 Select Simulate > Simulate from the main Schematic 
window to perform the transient simulation.

8 When the simulation has completed select Window > Open 
New Data Display.

9 From the Data Display main menu select File > Open... 

10 Select the file SingleVia_sharp_pulse_response.dds and 
click Open.

The following plot should appear in the Data Display 
window.

Figure 17 Transient Simulation Plot of BBS2P

11 To verify that the other ADS model (which makes use of 
controlled sources) of the broadband SPICE output model 
works as well as the rational polynomial model in ADS 
transient simulation, change the BBS2P ModelFile 
parameter value from Model_SingleVia.bbn to 

NOTE This plot shows the results of the transient analysis of the generated 
SPICE model. It is the voltage at nodes Vin and Vout vs. time.
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Model_SingleVia.ckt and re- run the simulation. The 
results are illustrated in the following plots:

.

This demonstrates how easily Broadband SPICE generated 
output can be used in ADS transient circuit simulations.
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Verifiying the Rational Fitting Model for the 
CoupledMicrostrip Lines

You can verify the rational model data and output ADS 
models for the CoupledMicrostrip lines example by following 
the same procedures outlined in, “Verifying the Rational 
Fitting Model Data for the SingleVia Structure” on page 44 
and “Verifying the Output Model for the SingleVia Structure” 
on page 48.
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Using the CoupledMicrostrip Lines Model in the Time Domain

1 In a Schematic window, select File > Open Design. Locate 
and open the design Coupledmicrostrip_TimeDomain.dsn

2 The following circuit should appear in the schematic 
window.

Figure 18 Transient Simulation of the Broadband SPICE Component

A transient simulation of the model represented by the 
BBS4P component has been set- up in this schematic. The 
following steps will ensure that the BBS4P component is 
set- up to correctly represent the Broadband SPICE model 
generated in the example “Model Creation Using an FR4 
Coupled- Microstrip Lines Circuit” on page 35. 

3 Double- click the BBS4P component. To bring up the Edit 
Parameter window.

4 Click Browse button with the ModelFile parameter 
selected.
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Since the .bbn file was not created for this model (refer 
to, “Model Generation for the FR4 Coupled- Microstrip 
Lines Circuit” on page 38) we will use the .ckt file 
instead. Because of this, “All Files” will need to be 
selected in order to be make the .ckt file to selectable. 

5 Select the file Model_Coupledmicrostrip.ckt, click Open.

6 Click OK to dismiss the Edit Parameters dialog.

7 Select Simulate > Simulate from the main Schematic 
window to perform the transient simulation.

8 When the simulation has completed the Data Display 
window will open and display:

Model_Coupledmicrostrip_sharp_pulse_response.dds 

The following plot should appear in the Data Display 
window:

NOTE Model_Coupledmicrostrip.ckt is the ADS broadband SPICE output model 
file created and saved during the Broadband SPICE Model Generation. 
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Figure 19 Transient Simulation Plot of BBS4P

It is clear that in this example, that there is a significant 
delay due to the length of the line. As you can see on the 
figure, the delay is about 0.9 ns. You can also see the ringing 
effect, which confirms the 0.9 ns travel time.

NOTE This plot shows the results of the transient analysis of the generated 
SPICE model. It is the voltage at nodes Vin and Vout vs. time.
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Recommendations and Tips

The following information may be useful, when using the 
Broadband SPICE Model Generation tool:

• If you have difficulties obtaining the required convergence 
accuracy or passivity level, we recommend that you to 
check the Input is from a measurement option on the 
Standard Options tab first.

• If the number of poles are too high, the .bbn ADS model 
file will not be created, in most cases. Should this occur, 
the .ckt file can be used in its place. However, if the .bbn 
file is available, we recommend that you use that file.

• Unless absolutely necessary, do not select .sp2 type as an 
your output file. The generation of this file demands extra 
calculation efforts and has lower numerical accuracy than 
the ADS model files and the .sp3 type.

• When using Advanced Input Options, we recommend 
selecting the ReducedX50 value in the Data sample 
section, especially if the number of frequencies is high. 
The engine automatically switches to a lower reduction 
scheme if more data samples are needed to determine a 
correct model. Note that the ReducedX field can not be 
applied to examples where the input file is a Momentum 
rational file type. For Momentum rational files, the AllX 
field should be used.

• The number of poles indicated in the Model section of the 
Advanced Input Options tab is an estimation based on 
the input data. This value can be changed, if you wish, to 
view the effect on the generated model. 

Generally, the estimated range of poles is adequate, 
however, you can adjust these ranges in order to obtain 
better results. This is especially the case when:

• The input data is very noisy, making it hard to estimate 
the dynamical behavior.
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• You have significantly modified the minimum and 
maximum frequencies. In this case, the number of poles 
will have to be adapted to the reduced frequency range. 
It is generally acceptable to set a wide range for the 
Minimum and Maximum number of poles if the correct 
number is not known.

• If there are too many ports and poles, simulation time 
can grow significantly. Unless required, skipping the 
passivity enforcement step can reduce the overall 
simulation time.

Since the passivity enforcement calculation step can take 
a large portion of the total model generation time, 
consider the following:

• If passivity enforcement is not needed and the a 
passive rational fitted model in not required, it is best 
to uncheck the Use global poles option in the Fitting 
section of the Advanced Input Options tab. 

• If passivity enforcement is not needed, but you want to 
know whether the fitted model is passive (without 
modifying the model to obtain passivity), you can check 
the Enforce passivity option, but set the Maximum 
number of iterations in the Passivity section to 0.

• If passivity enforcement is needed, you must set 
Enforce passivity option and select a number for the 
Maximum number of iterations, typically 5.

If the input data contains a large, dynamical system with 
many ports (and thus a large simulation time), it is a good 
practise to run several simulations using all of the above 
settings (and any other combinations, as you prefer) then 
save the output files with a different file name prefix, in 
order to compare the results using the Data Display.
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A Passive Broadband SPICE Model Reference
Overview

The Passive Broadband SPICE built- in components are 
available in the Schematic view of ADS under 
Passive- Broadband Spice Models section. 
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BBS1P(1-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 1- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (2) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
64 Broadband SPICE Model Generator



Passive Broadband SPICE Model Reference A
BBS2P (2-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 2- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (3) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
66 Broadband SPICE Model Generator



Passive Broadband SPICE Model Reference A
BBS3P (3-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 3- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (4) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS4P (4-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 4- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (5) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS5P (5-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 5- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (6) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS6P (6-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 6- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (7) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS7P (7-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 7- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (8) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS8P (8-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 8- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (9) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS9P (9-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 9- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to“Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (10) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBS10P (10-Port Broadband SPICE Model)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an 1- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 
sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (11) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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BBSnP (Port Broadband SPICE Model n>99)

Symbol

Parameters

Notes and Equations

1 The BBSnP component is used to represent an n- Port 
ADS model generated by the Broadband SPICE Model 
Generator tool. For information on Broadband SPICE 
model files, refer to “Using Broadband SPICE Models in 
ADS” on page 44.

2 Valid model file extensions are <filename>.bbn 
(rational- polynomial formulation) and <filename>.ckt 
(controlled sources formulation).

3 In general, the rational polynomial model (with the 
extension .bbn) is recommended over the controlled 

Name Description Units Default

ModelFile Name of data file containing n-port 
Broadband SPICE ADS model.

The directory path is optional. The default 
directory is <prj>/ where <prj> is your 
current project directory

None None
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sources model. If the number of ports and/or the number 
of poles associated with the model is large, though, the 
controlled sources (.ckt) model may provide better results.

4 Broadband SPICE models are implemented as subcircuits, 
defined in hpeesofsim netlist fragments. The name of the 
model’s top- level subcircuit is displayed in the BBSnP 
component’s Edit Parameters dialog when a valid 
ModelFile is specified.

5 Ref pin (n+1) is the common terminal; it is normally 
grounded, but can be used in non- grounded mode.

6 This component has no default artwork associated with it.
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