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Nominal Design

Trace: length=10mm, width=1mm, thickness=0.1mm

Via: radius=0.5mm, height=0.9mm

Ground: thickness=0.1mm

Board: thickness=0.9mm, relative permittivity εr=1
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Getting Started

1. Launch HFSS:
Start button ⇒ All Programs ⇒ ANSYS Electromagnetics ⇒ HFSS 15.0
⇒ Windows 64-bit ⇒ HFSS 15.0

2. Set HFSS options:
Tools ⇒ Options ⇒ HFSS Options ⇒ General Tab

check XUse Wizards for data input when creating new
boundaries
check XDuplicate boundaries/mesh operations with geometry
click OK
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3. Set Modeler options:
Tools ⇒ Options ⇒ Modeler Options ⇒
Operation Tab

check XAutomatically cover closed polylines
check XSelect last command on object select

Drawing Tab

check XEdit properties of new primitives

Click OK
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4. New Project

A new project called Project 1 is created by default, or you can
create a new project from File ⇒ New
Right click on Project 1 and select Rename (F2), you can
rename the project as helloHFSS

5. New HFSS Design

Right click on helloHFSS ⇒ Insert ⇒ Insert HFSS Design
Rename the HFSS Design as via and trace
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Hello HFSS!

Now you should have a workspace as below
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Creating the 3D model

1. Set solution type:
HFSS ⇒ Solution Type ⇒ Driven Terminal ⇒ OK
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Creating the 3D model

2. Set model unit:
Modeler ⇒ Units ⇒ Select mm ⇒ OK
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Creating the 3D model

3. Set default material:
Open material tool bar ⇒ type pec in the Search by Name field ⇒ Click
OK

Open material tool bar
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Creating the 3D model

type pec in the Search by Name field
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Creating the 3D model

Click Ok and the default material has been changed to pec

Tianjian Lu ECE 546: ANSYS HFSS Tutorial



Problem Description
Getting Started

Create the 3D model
Analysis Setup

Plot S-parameters vs. Frequency

Create Trace

There are multiple ways to specify the position and dimensions of a trace, or
any shape in general

One way is to enter the information in the coordinate entry fields.
Variables are not allowed in the coordinate entry fields.

Another way is to draw an arbitrary box first and modify its position and
dimensions with variables.

Using variables is encouraged as it is easier for changes to be made on
the designs.

Here, we first create a box in the 3D modeler window and then redefine
its position and dimensions with variables.
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Create Trace

1. Define variables
HFSS ⇒ Design Properties ⇒ add w trace = 1 mm, l trace = 10 mm,
and t trace = 0.1 mm as local variables; w trace, l trace, and t trace
represent the width, length, and thickness of the trace, respectively
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2. Draw a box
Draw ⇒ Box
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3. Click three times in the 3D modeler window to create an arbitrary
box

first click to define the position of the box
second click to specify the lateral dimensions
third click to create the height of the box
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4. Specify the dimensions and position with variables
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Create Trace

5. Change the attributes
Double click on Box1 for the attribute menu, change the name to trace,
color to red, and set the transparency to 0.5.
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6. View the information of the created trace
Double click on Create Box under trace, one is able to see the Position,
XSize, YSize, and ZSize of the created trace in the figure below
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7. Fit the view in the 3D modeler window
CTRL + D

8. Done with the trace!

Try the two useful tricks in the 3D modeler window

Shift + Mouse left
Alt + Mouse left

What did you find?
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Create Via Pad

1. Define variables
HFSS ⇒ Design Properties ⇒ add r pad = 0.75 mm, t pad = 0.1 mm,
as the radius and the thickness of the via pad, respectively.
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2. Draw a cylinder

Draw ⇒ Cylinder
Again, three clicks in the 3D modeler window: the first click to
specify the center of the cylinder, the second click to define
the radius, and the third click for the height
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3. Position and Dimensions
Enter the position and the dimensions of the created cylinder as shown in
the figure below.
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4. Change the attributes
Double click on Cylinder 1 for its attribute menu, change the name to
Via pad and color to red, and set the transparency to 0.5.
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5. Unite trace and pad

Edit ⇒ Select All Visible or CTRL+A
Modeler ⇒ Boolean ⇒ Unite
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Create Ground Plane

1. Define variables
HFSS ⇒ Design Properties ⇒ add t plane = 0.1 mm,
w plane = 20 mm, l plane = 40 mm, and t dielectric = 0.1 mm
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t plane, w plane, and l plane denote the thickness, the
width, and the length of the plane, respectively;

t dielectric denotes the thickness of the dielectric layer
between the trace and its neighboring ground;

the lateral dimensional of the dielectric layer is chosen as the
same as that of the ground plane.
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2. Draw a box
Draw ⇒ Box
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3. Similar to creating the trace, click three times in the 3D modeler
window for an arbitrary box

first click to define the position of the box
second click to specify the lateral dimensions
third click to create the height of the box
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4. Specify the dimensions and position with variables
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Create Ground Plane

5. Change the attributes
Double click on Box 1, rename it as GND, set the color to green, and
modify the transparency to 0.7.
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Side-view of the ground plane and the trace(pad)
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3D-view of the ground plane and the trace(pad)
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Create Anti-Pad

1. Define variables
HFSS ⇒ Design Properties ⇒ add r antipad = 1 mm, the height of the
anti-pad should be identical to the thickness of the ground plane
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2. Draw a cylinder
Draw ⇒ Cylinder and specify the dimensions with variables.
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3. Change the attributes
Double click on Cylinder 1 for its attribute and rename it as Antipad

Tianjian Lu ECE 546: ANSYS HFSS Tutorial



Problem Description
Getting Started

Create the 3D model
Analysis Setup

Plot S-parameters vs. Frequency

Create Anti-Pad

4. Boolean Operation

Edit ⇒ Select ⇒ By Name ⇒ select GND and Antipad
Modeler ⇒ Boolean ⇒ Subtract ⇒ Bland parts: GND; Tool
parts: Antipad ⇒ Click OK
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1. Draw Rectangle

Modeler ⇒ Grid Plane ⇒ XZ
Draw ⇒ Rectangle
Specify the dimensions as the figure below
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2. Rename as source
Double click on Rectangle 1 and rename it as source
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3. Assign lumped port

Edit ⇒ Select ⇒ By Name ⇒ select source ⇒ HFSS ⇒
Excitations ⇒ Assign ⇒ Lumped port
Set the lumped port as shown in the picture:
Port name to 1;
select conductor GND and check XUse as Reference;
check XHighlight selected conductors ⇒ Click OK
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4. Renormalizing impedance

In the Project Manager, expand Excitations and rename
trace T1 as T1
The renormalizing impedance of the lumped port is by default
50 Ohms
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5. Highlight the lumped port
Again under Excitations in the Project Manager, if you click on 1, the
lumped port is highlighted.
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Create Multilayers by Duplication

1. Define variables
HFSS ⇒ Design Properties ⇒ add t separate = 0.45 mm
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2. Create Offset Coordinate System
Modeler ⇒ Coordinate System ⇒ Create ⇒ Relative CS ⇒ Offset
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3. Set the Offset Coordinate System
Click on the 3D modeler window and set the RelativeCS1 as shown in the
figure
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4. Perform the Duplication

Edit ⇒ Select All Visible or CTRL + A
Modeler ⇒ Coordinate System ⇒ Set Working CS ⇒
RelativeCS1
Edit ⇒ Duplicate ⇒ Around Axis
Set the duplication parameters as shown in the picture in the
next page
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4. Perform the Duplication
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Side-view of the multilayered structure
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Create Multilayers by Duplication

3D-view of the multilayered structure

Tianjian Lu ECE 546: ANSYS HFSS Tutorial



Problem Description
Getting Started

Create the 3D model
Analysis Setup

Plot S-parameters vs. Frequency

Create Via

1. Define variables

Modeler ⇒ Coordinate System ⇒ Set Working CS ⇒
RelativeCS1
HFSS ⇒ Design Properties ⇒ add t via = 2 ∗ t separate and
r via = 0.5 mm
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2. Draw a cylinder
Draw ⇒ Cylinder and specify the dimensions and position as the figure
below
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3. Change attributes
Double click on Cylinder 1 and rename it as Via
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Create Dielectric Layer

1. Select material
Use 3D modeler materials toolbar, choose vacuum
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Create Dielectric Layer

2. Draw Box
Draw ⇒ Box and specify the dimensions and position as the figure below
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3. Change attributes
Rename it as board
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Create Airbox

1. Define variables
Define w air = 30 mm, l air = 50 mm, and t air = 10 mm
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2. Draw Box
Draw ⇒ Box and specify the dimensions and position as the figure below
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3. Change attributes
Rename it as air
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4. Assign perfect-H boundary

Edit ⇒ Select ⇒ By Name ⇒ air ⇒ Click OK
HFSS ⇒ Boundaries ⇒ Assign ⇒ Perfect H ⇒ Click OK

5. Override Material

HFSS ⇒ Design Settings ⇒ Enable Material Override
check XEnable Material Override
click OK
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Create an Analysis Setup

1. Create an Analysis
HFSS ⇒ Analysis Setup ⇒ Add Solution Setup ⇒ General tab

Solution Frequency: 10 GHz
Maximum number of passes: 20
maximum Delta S: 0.02
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Create an Analysis Setup

2. Options tab
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Create an Frequency Sweep

3. HFSS ⇒ Analysis Setup ⇒ Add Frequency Sweep ⇒ Edit the sweep as
the figure below ⇒ click OK
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Validation Check and Analyze All

4. HFSS ⇒ Validation Check

click Close if all pass
Use Message Manager to view any warning or error message

5. HFSS ⇒ Analyze all

Tianjian Lu ECE 546: ANSYS HFSS Tutorial



Problem Description
Getting Started

Create the 3D model
Analysis Setup

Plot S-parameters vs. Frequency

Plot S-parameters vs. Frequency

6. HFSS ⇒ Results ⇒ Create Terminal Solution Data Report ⇒
Rectangular Plot

Solution: Setup1:Sweep1
Domain: Sweep
Category: Terminal S Parameters
Quantity: St(T1,T1), St(T1,T2)
Function: dB
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